Friday, August 29, 2008

Wireless Universal Client Mode

Universal client mode is a wireless radio station role that allows the radio to act as a wireless client to another access point or repeater. This feature is exclusive to the integrated radio running in the Cisco 870, 1800, 2800, and 3800 Integrated Services Routers. It operates differently from the workgroup bridge and non-root bridge modes that are supported on other Cisco wireless devices such as the Cisco AP 1200.

Universal client mode has the following features and limitations:
• You can configure universal client mode on the main dot11radio interface only, sub-interfaces are not supported.
• Universal client can associate to access points with radio VLANs.
• Layer-3 routing is supported over the radio interface. However, there is no support for L2-bridging. The user cannot configure a dot11radio interface with a bridge-group when in universal client mode.
• SSIDs are required to be configured on the dot11 interface operating as a universal client; association to an access point running in guest-mode is not supported.
• The universal client can associate to Cisco access points, 3rd party access points, and repeaters. It cannot associate to Cisco root bridges or Cisco workgroup bridges.

Configuring Universal Client Mode You can configure universal client mode in Cisco ISR series by setting the radio interface station-role to non-root. This is different from configuring the dot11radio interface to operate in non-root bridge mode, which requires specifying the word bridge at the end of the command, ex: "station-role non-root bridge". But in Access Points both station-role non-root and station-role non-root bridge are the same. On the ISRs, the two commands are different: station-role non-root is considered the universal client mode and station-role non-root bridge is considered the non-root bridge mode. Also note that NAT fails to translate with a DHCP address on the dot11 interface running in universal client mode.
========================
Configuration on Access Point 1242:
========================
dot11 ssid Cisco
authentication open
!
bridge irb
!
interface Dot11Radio0
no ip address
no ip route-cache
!
ssid Cisco
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root access-point
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!
interface FastEthernet0
no ip address
no ip route-cache
duplex auto
speed auto
bridge-group 1
no bridge-group 1 source-learning
bridge-group 1 spanning-disabled
hold-queue 160 in
!
interface BVI1
ip address 192.168.1.10 255.255.255.0
no ip route-cache
!
ip default-gateway 192.168.1.254
!
bridge 1 protocol ieee
bridge 1 route ip
====================
Configuration on Router 1841:
====================
dot11 ssid Cisco
authentication open
infrastructure-ssid
!
interface FastEthernet0/0
ip address 172.16.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
no ip route-cache cef
no ip route-cache
duplex auto
speed auto
no keepalive
!
interface Dot11Radio0/0/0
ip address 192.168.1.70 255.255.255.0
ip nat outside
ip virtual-reassembly
no ip route-cache cef
no ip route-cache
!
ssid Cisco
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role non-root
!
ip route 0.0.0.0 0.0.0.0 192.168.1.254
!
ip nat inside source list 7 interface Virtual-Dot11Radio0 overload
!
access-list 7 permit 172.16.1.0 0.0.0.255

1 comment:

jgrement said...

Hi, I want to make this configuration, but I have a requirement that is my question.

If I use Universal Client Mode, Am I stil using the router wireless conection with my laptop?

this because I need to connect an IP phone to an ethernet port in the router, one Tandberg y other port, and a laptop via wireless. is this possible?

Thanks in advance?